Resolved
Now there's no issue, it has resolved
Monitoring
When the User click "submit" at submit startup, the process then goes on unending "submitting". We had identified and tried to fix this, but "trial and error" still needed to ensure the next actions regarding user's feedback, and submission process smoothly. Thank you for your understanding, feedback, and attention. Please contact us if there's any bug during the submission process, we'll gladly fix it.